System Requirements for Using SafeScript

This topic lists the minimum requirements for using the SafeScript portal, and/or the SafeScript Notification App.

SafeScript Portal

Web browsers

Supported browsers include:

  • Google Chrome version 58 and higher.
  • Microsoft Internet Explorer versions 10 and 11.
  • Mozilla Firefox version 52 and higher.
  • Apple Safari version 10 and higher.
  • Microsoft Edge version 13 and higher.

Screen resolution

The SafeScript portal is designed for a minimum screen resolution of 1024×768 pixels.

Operating systems

Windows, MacOS, and iOS systems capable of running the minimum supported web browser versions are supported.

Third-Party Cookies need to be enabled in your web browser. For details, see How to Enable Cookies.

SafeScript Web App for Mobile Phones

The following operating systems and browsers are supported.

  • Apple: iOS 10.3 and above running Safari, Firefox or Chrome
  • Android: Android 8.0 'Oreo' and above running Chrome or Firefox

Notification App

Windows 7 or higher is supported.

Tap to return to the top of the page